IS Forum
Forum Index Register Members List Events Mark Forums Read Help

Go Back   International Skeptics Forum » General Topics » Computers and the Internet
 


Welcome to the International Skeptics Forum, where we discuss skepticism, critical thinking, the paranormal and science in a friendly but lively way. You are currently viewing the forum as a guest, which means you are missing out on discussing matters that are of interest to you. Please consider registering so you can gain full use of the forum features and interact with other Members. Registration is simple, fast and free! Click here to register today.
Tags laptops , linux , sleep mode

Reply
Old 7th November 2011, 08:47 AM   #1
Zelenius
Muse
 
Zelenius's Avatar
 
Join Date: Jul 2008
Posts: 908
Smile Linux Mint laptop looses internet connection after resuming from sleep mode

This seems to be a common problem for many newbie Linux users like me. The laptop I am using is a relatively new Toshiba Satellite. It used to have Windows on it, but then I formatted the hard drive and switched to Ubuntu. Although I didn't lose the internet connection with Windows or Ubuntu when it went into sleep mode, I despise Microsoft and I hated the Unity interface of Ubuntu and switched to Linux Mint.

With the laptop I connect to the internet with my own wireless router(I get my broadband from the phone company and they provided the router). I use WPA security for the wifi signal. The internet works great and is fast, but if the laptop goes to sleep, upon resuming the connection is dead - even Wicd can't find my router or any wifi signals(it can normally detect around 10 of them from my neighbors). The only way to get my internet connection back is to restart my laptop, and I hate having to do this since it is time consuming and may damage the laptop. I tried to disabled sleep mode(first from the control center then from the BIOS) but it still goes into sleep mode. It needs to be on throughout the day for work; I do turn it off every night though.

This also happens to the laptop when I connect to the same router with an ethernet cable(I rarely use an ethernet connection for this laptop). Upon coming out of sleep(or suspend) mode, the internet connection is dead, but unlike with the wireless connection, Wicd can detect the ethernet connection but can't connect to it. I have a desktop computer with Linux Mint that is connected to the same router as the laptop but with an ethernet cable and it never loses its internet connection after coming out of sleep mode.

After typing "iwconfig" at terminal I get:

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"VVBBVDF"
Mode:Managed Frequency:2.437 GHz Access Point: xx:xx:xx:xx:xx:xx
Bit Rate=19.5 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thrff
Power Managementff
Link Quality=69/70 Signal level=-41 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:135 Missed beacon:0

Also, in accessing the properties of my connection VVBBVDF in Wicd, just about everything, including "use static IPs", along with the info related to this, "use static DNS", "DHCP Hostname", and "Use these settings for all Networks sharing this essid" are not checked or blank. The only thing that is checked is "Use encryption".

I suspect this problem is security or WPA related. Thanks if you read this entire thing
Zelenius is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Old 7th November 2011, 09:41 AM   #2
Chungy
Guest
 
Join Date: Oct 2011
Posts: 49
I booted up on Mint (usb) to make this post, and see if mine had same issue, but sleep and hibernate do not function from USB.

If your only issue with Ubuntu Oneric Ocelot 11.10 is the Unity display, it is very simple to just turn it off. All you have to do at login screen is click on little gear icon by where you type user name and you can switch to old gnome version. I have 11.10 Ubuntu on my hard drive, and I do like Unity, however I only have 1gig RAM so I can not watch videos with Unity as it chews up memory. It works great for all other things.

Funny thing is when i booted up the Mint, the factory home page is

www.forums.linuxmint.com

If you are dead set on staying with Mint, I am sure answer is there.
Chungy is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Old 7th November 2011, 10:21 AM   #3
TheL8Elvis
Philosopher
 
TheL8Elvis's Avatar
 
Join Date: May 2011
Posts: 8,276
At the risk of oversimplifying, have you tried bringing your wireless interface down and back up ? May not solve the problem, but may make it usable:
from a terminal
sudo ifconfig wlan0 down
sudo ifconfig wlan0 up
TheL8Elvis is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Old 7th November 2011, 10:37 AM   #4
Wudang
BOFH
 
Wudang's Avatar
 
Join Date: Jun 2003
Location: People's Republic of South Yorkshire
Posts: 13,586
When I installed mint on my old HP laptop it offered to install proprietary drivers for the wireless card. Did you see that?
__________________
"Your deepest pools, like your deepest politicians and philosophers, often turn out more shallow than expected." Walter Scott.
Wudang is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Old 7th November 2011, 11:43 AM   #5
Zelenius
Muse
 
Zelenius's Avatar
 
Join Date: Jul 2008
Posts: 908
Originally Posted by Wudang View Post
When I installed mint on my old HP laptop it offered to install proprietary drivers for the wireless card. Did you see that?
Yes. I did that and had them installed.
Zelenius is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Old 7th November 2011, 11:50 AM   #6
Zelenius
Muse
 
Zelenius's Avatar
 
Join Date: Jul 2008
Posts: 908
Originally Posted by TheL8Elvis View Post
At the risk of oversimplifying, have you tried bringing your wireless interface down and back up ? May not solve the problem, but may make it usable:
from a terminal
sudo ifconfig wlan0 down
sudo ifconfig wlan0 up
When the laptop is connected to the internet, typing "sudo ifconfig wlan0 down" disconnects me, and "sudo ifconfig wlan0 up" gets me back on the net. However, after resuming from suspend mode "sudo ifconfig wlan0 up" doesn't connect me to the internet through my router. Wicd can't even find any wifi signals at all, not even my neighbors. This didn't work, but thanks.
Zelenius is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Old 7th November 2011, 12:19 PM   #7
TheL8Elvis
Philosopher
 
TheL8Elvis's Avatar
 
Join Date: May 2011
Posts: 8,276
Originally Posted by Zelenius View Post
after resuming from suspend mode "sudo ifconfig wlan0 up" doesn't connect me to the internet through my router. .
It may have been implied in your description, but after suspend did you do bring the interface down, then up ? or just do ifconfig wlan0 up ?
TheL8Elvis is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Old 7th November 2011, 02:12 PM   #8
Chungy
Guest
 
Join Date: Oct 2011
Posts: 49
There appears to be a couple different choices in software management for network manager on my Mint distro perhaps your computer will prefer different one. It's an easy test to install and see.

I know I switched to wicd on my ubuntu install and had better luck switching back to the native manager, you may have already tried this?

Last edited by Chungy; 7th November 2011 at 02:13 PM.
Chungy is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Old 7th November 2011, 05:41 PM   #9
Zelenius
Muse
 
Zelenius's Avatar
 
Join Date: Jul 2008
Posts: 908
Originally Posted by Chungy View Post
There appears to be a couple different choices in software management for network manager on my Mint distro perhaps your computer will prefer different one. It's an easy test to install and see.

I know I switched to wicd on my ubuntu install and had better luck switching back to the native manager, you may have already tried this?
Man do I feel stupid. I just got rid of Wicd and switched back to the native network manager and it worked! Thanks! Now the internet works after resuming from suspend mode without having to reboot. I thought resolving this issue was going to be a lot more difficult.

Thanks again!
Zelenius is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Old 7th November 2011, 06:27 PM   #10
Chungy
Guest
 
Join Date: Oct 2011
Posts: 49
Originally Posted by Zelenius View Post
Man do I feel stupid.
No need for that. I feel better for being able to offer proper suggestion, as I had just been switching mine recently.

I can feel stupid when I have to post on the Ubuntu forum or in Linux forum, people there can sometimes make you feel like dirt. Plus the action there can be painfully slow, I think they avoid answering questions that seem obvious, as to not risk expert status among the old time posters. What really gets me is the old timers that just rattle off many sudo commands to beginners, that is just plain rude since they don't take time to make copy pasta, especially when the question asker says "I am new to Linux". What a turn off.

It's another thing I like about Linux, if part of OS isn't working for you, you change that part, 1.2.3. I'm not even sure if new windows allows this, I remember network manager with Vista was complete garbage, my friend had one.
Chungy is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Old 7th November 2011, 07:03 PM   #11
Wudang
BOFH
 
Wudang's Avatar
 
Join Date: Jun 2003
Location: People's Republic of South Yorkshire
Posts: 13,586
Proprietary add-ons like the HP connections manager that came with the XP installed on my HP laptop can really get in the way as well. A good place to ask questions is the various subareas of stackexchange.com. There are a few ******** but their responses get voted down I usually find.
__________________
"Your deepest pools, like your deepest politicians and philosophers, often turn out more shallow than expected." Walter Scott.
Wudang is offline   Quote this post in a PM   Nominate this post for this month's language award Copy a direct link to this post Reply With Quote Back to Top
Reply

International Skeptics Forum » General Topics » Computers and the Internet

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -7. The time now is 01:41 AM.
Powered by vBulletin. Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum began as part of the James Randi Education Foundation (JREF). However, the forum now exists as
an independent entity with no affiliation with or endorsement by the JREF, including the section in reference to "JREF" topics.

Disclaimer: Messages posted in the Forum are solely the opinion of their authors.